The Ultimate SCSI2SD For Samplers Site - the Final Word

Article - Use The Correct Utility Version, Not Necessarily The Latest

2019-08-01 (Last Update: Thu, 01 Aug 2019) Garth Hjelte 0 General

 

Due to the wide availability of SCSI2SD boards, your SCSI2SD board may not necessarily have the latest firmware on it, and it's also not really advisable to update it if your board works perfectly for you.

That being said, let's talk about the SCSI2SD Utility you can get from the CodeSrc website. As you can see, there are many versions listed, and you may be tempted to download the latest one regardless of the firmware version you have.

However, you should get the Utility version that matches your firmware version, if your goal is to change the start/length numbers or ID numbers. Do not get the latest firmware version UNLESS your goal is to upgrade older firmware to the latest firmware.

Lastly, do not assume that the latest firmware is better. Newer firmware has been known to introduce bugs regarding certain samplers. Be sure to read the History posted on CodeSrc, and only upgrade if you know it actually fixes something.

Comments are disabled.